Name

AlwaysSecure — specify pages that are always to be served over a HTTPS connection

SYNOPSIS

page_path...

DESCRIPTION

The directive specifies Interchange pages that are always to be served over a secure (HTTPS) connection.

DIRECTIVE TYPE AND DEFAULT VALUE

Catalog directive

EXAMPLES

Example: Specifying AlwaysSecure

AlwaysSecure ord/checkout

AlwaysSecure   <<EOD
  change_password
  login
  member/account
  ord/billing
  ord/checkout
  ord/finalize
  ord/multi
  ord/shipping
  query/order_detail
EOD

NOTES

AVAILABILITY

AlwaysSecure is available in Interchange versions:

4.6.0-5.9.0 (git-head)

SOURCE

Interchange 5.9.0:

Source: lib/Vend/Config.pm
Line 647

['AlwaysSecure',   'boolean',         ''],

Source: lib/Vend/Config.pm
Line 3006 (context shows lines 3006-3023)

sub parse_boolean {
my($item,$settings) = @_;
my(@setting) = grep /\S/, split /[\s,]+/, $settings;
my $c;

if(defined $C) {
  $c = $C->{$item} || {};
}
else {
  no strict 'refs';
  $c = ${"Global::$item"} || {};
}

for (@setting) {
  $c->{$_} = 1;
}
return $c;
}

AUTHORS

Interchange Development Group

SEE ALSO

ExtraSecure(7ic)

DocBook! Interchange!