Skip to main content.

Interchange News

  • Interchange 5.4.1 released

    Posted on 26-May-2006 by Jon Jensen

    The Interchange Development Group is pleased to announce the release of Interchange 5.4.1, the latest production-ready version of our web application server. This is a maintenance release and upgrading from Interchange 5.4.0 should present no compatibility problems. The main changes are: * Fixed bugs in the ITL parser that can cause an infinite loop when malformed ITL opening tags are encountered. * Fixed a regression in htmlarea widget which kept it from working with Internet Explorer and browsers claiming to be compatible. * Fixed a profile parsing bug when a comment immediately precedes the __NAME__ identifier. * Check for "GoogleBot", rather than just "Google", in the default RobotUA list, to prevent confusion with other UA values such as "GoogleToolbar". * Improvements to Linkpoint and VeriSign payment modules. * Support recent versions of mod_perl 2 in Interchange::Link. * Updated UPS Postal rates in Standard demo's shipping tables. * Numerous minor bugfixes in core code, tags, the admin, and the Standard demo. Jon Jensen Interchange Development Group PGP key: http://ftp.icdevgroup.org/keys/jon-jensen-dccac084.txt

News archive