[interchange-cvs] interchange - racke modified debian/interchange.templates

interchange-cvs at icdevgroup.org interchange-cvs at icdevgroup.org
Wed Jan 31 06:27:28 EST 2007

User:      racke
Date:      2007-01-31 11:27:28 GMT
Modified:  debian   interchange.templates
merged changes 2.8 vs
+++ +++
  * require versions of Perl and DBI which allow to run Interchange
    without (known) crashes with threaded Perl (Closes: #339335, thanks to
    Henrik Holmboe <henrik at holmboe.se>)
  * removed notice about threaded Perl and no longer set MV_GETPPID_BROKEN

Revision  Changes    Path
2.9       +0 -10     interchange/debian/interchange.templates

rev 2.9, prev_rev 2.8
Index: interchange.templates
RCS file: /var/cvs/interchange/debian/interchange.templates,v
retrieving revision 2.8
retrieving revision 2.9
diff -u -r2.8 -r2.9
--- interchange.templates	22 Sep 2005 15:19:18 -0000	2.8
+++ interchange.templates	31 Jan 2007 11:27:28 -0000	2.9
@@ -113,13 +113,3 @@
  /etc/interchange/robots.cfg for the directives RobotUA, RobotIP and
  RobotHost. It is recommended to include these settings so that Interchange can
  distinguish between robots and ordinary users.
-Template: interchange/threadenabledperl
-Type: note
-_Description: Important Perl Incompatibility
- The authors of Interchange strongly disencourage the use of their software
- on top of a thread enabled Perl. It is likely to cause serious problems,
- especially in high load situations, and has no benefit at all for
- Interchange servers. The development team asserts that the thread-safeness
- of Perl and the bunch of modules Interchange uses can hardly be relied upon.
- Please use this package only for testing and debugging purposes.

More information about the interchange-cvs mailing list