[ic] Updating the variables database

Matthew Schick mschick@brightredproductions.com
Fri, 01 Dec 2000 00:22:14 -0600

Hey All,

         I seem to have run into a problem with the variables database.  I 
am trying to make a page to update some of the more common values and 
cannot seem to get it to work...... Here is my code:

<form action="[area ui]" method="post">
<INPUT TYPE=hidden NAME=mv_doit VALUE="set">
<INPUT TYPE=hidden NAME=mv_click VALUE="process_filter">
<INPUT TYPE=hidden NAME=mv_nextpage VALUE="admin/prefs">
<INPUT TYPE=hidden NAME=mv_data_table VALUE="variable">
<INPUT TYPE=hidden NAME=ui_meta_specific VALUE="">
<INPUT TYPE=hidden NAME=ui_hide_key VALUE="">
<INPUT TYPE=hidden NAME=ui_display_only VALUE="">
<INPUT TYPE=hidden NAME=ui_meta_view VALUE="">
<INPUT TYPE=hidden NAME=item_id_left VALUE="">
<INPUT TYPE=hidden NAME=ui_sequence_edit VALUE="">
<INPUT TYPE=hidden NAME=mv_data_key VALUE="code">
<INPUT TYPE=hidden NAME=mv_data_decode VALUE="">
<INPUT TYPE=hidden NAME=mv_update_empty VALUE="1">

<INPUT TYPE=hidden NAME="mv_data_function" VALUE="update">
[display table=variable column=Variable key=BGCOLOR]
<INPUT TYPE=hidden NAME=mv_data_fields VALUE="Variable">
<INPUT TYPE="submit" NAME="mv_click" VALUE="Ok">
<INPUT TYPE=checkbox NAME=mv_auto_export CHECKED VALUE="variable">

The error log shows this error: 6mBrpMRu: - [30/November/2000:23:59:02 -0600] 
construct /cgi-bin/construct/ui.html No key 'code' found for 
function='update' table='variable'

I have tried looking thru the mailing list and the docs, but all to no 

Any suggestions would be very cool....

Matthew Schick
Bright Red Productions, LLC
"Web Design With A Pulse!"