[ic] Updating the variables database

Mike Heins mikeh@minivend.com
Fri, 1 Dec 2000 08:38:24 -0500

Quoting Matthew Schick (mschick@brightredproductions.com):
> Hey All,
>          I seem to have run into a problem with the variables database.  I 
> am trying to make a page to update some of the more common values and 
> cannot seem to get it to work...... Here is my code:
> <form action="[area ui]" method="post">
> <INPUT TYPE=hidden NAME=mv_doit VALUE="set">
> <INPUT TYPE=hidden NAME=mv_click VALUE="process_filter">
> <INPUT TYPE=hidden NAME=mv_nextpage VALUE="admin/prefs">
> <INPUT TYPE=hidden NAME=mv_data_table VALUE="variable">
> <INPUT TYPE=hidden NAME=ui_meta_specific VALUE="">
> <INPUT TYPE=hidden NAME=ui_hide_key VALUE="">
> <INPUT TYPE=hidden NAME=ui_display_only VALUE="">
> <INPUT TYPE=hidden NAME=ui_meta_view VALUE="">
> <INPUT TYPE=hidden NAME=item_id_left VALUE="">
> <INPUT TYPE=hidden NAME=ui_sequence_edit VALUE="">
> <INPUT TYPE=hidden NAME=mv_data_key VALUE="code">
> <INPUT TYPE=hidden NAME=mv_data_decode VALUE="">
> <INPUT TYPE=hidden NAME=mv_update_empty VALUE="1">
> <INPUT TYPE=hidden NAME="mv_data_function" VALUE="update">
> [display table=variable column=Variable key=BGCOLOR]
> <INPUT TYPE=hidden NAME=mv_data_fields VALUE="Variable">
> <INPUT TYPE="submit" NAME="mv_click" VALUE="Ok">
> <INPUT TYPE=checkbox NAME=mv_auto_export CHECKED VALUE="variable">
>                  Auto-export
> The error log shows this error:
> 6mBrpMRu: - [30/November/2000:23:59:02 -0600] 
> construct /cgi-bin/construct/ui.html No key 'code' found for 
> function='update' table='variable'

I don't see <INPUT NAME=code> above.... isn't the error message

Akopia, Inc., 131 Willow Lane, Floor 2, Oxford, OH  45056
phone +1.513.523.7621 fax 7501 <heins@akopia.com>

For a successful technology, reality must take precedence over public
relations, for Nature cannot be fooled. -- Dick Feynman