[ic] New user needs assitance

Steve & Patti Getzinger steveandpatti@wubs.org
Sun, 17 Dec 2000 09:29:59 -0500

+N6REJ wrote:

> Hello, I just installed interchange 4.6 and I'm having some problems with
> getting it running.
> I'm running RedHat 6.2
> 1: exactly how do I go about making it start on boot.

Depends on the install you did. rpm or tarball?

> 2. when starting it as user interch I was forced to give that user /bin/bash
> permissions in order to get interchange to start.. is this ok?  I have not
> assigned a pw as of yet.

You did something wrong

> 3. Even though interchange is running and I have the following in the vhost
> section in /usr/local/apache/conf/httpd.conf
> ScriptAlias /cgi-bin/ "/www/worldspecialt.net/cgi-bin/"
> Whenever I try to access any of the cgi based files.. like, clik here if ur
> a customer, it says interchange is'nt running.

Then it isn't. How do you know it is running? Again what install method did you
use. And how did you start the server

> 4. I was unable to find any demo's other then "Construct" is this ok?

What other demos did you install? Construct is the only one (that I know of)
that is "packaged" with IC

> 5. How do I set things up so that it uses PGP?

Read the docs

> 6. How will it know when to go to a secure area and when not to?

It is magic and happens automagically. Again this is in the docs. If you are
not getting the answers you need from the docs on the IC site go to the old MV
site and go through those docs. Knowing where it came from will greatly help in
knowing where it is.

> Thanks in advance
> Troy

Hope that helps some. If you need specific help I am running on RH6.2 on the
Net and RH6.2 and 7 on development machines. I would highly recommend dumping
whatever install you presently have and downloading the rpm. Then do an install
with the rpm. On a clean RH6.2 box everything will be just fine as far as
permissions and install areas. It will also be loaded into init and start on
reboot of the machine. Starting the server is done from init and not the
bin/start of IC. bin/start will report the server running on RH with top or ps
but will not run the sites.

Hope that helps