[ic] Premature end of script headers ... ERROR

Andrei Gologan info@ag-it.de
Tue, 31 Oct 2000 20:34:18 +0100


I allready spent more than 2 days to this now, and I canīt get it to work.....
Letīs forget about running Interchange in UNIX mode,  but  INET doesnīt work as
well !

OK to the facts:

Red Hat 6.1
Apache - 1.3.12 mit Suexec enabled.
Apache runs as httpd:shadow
Perl 5.006
Interchange 4.6
all installation runs thru,
Interchange runs as interch:interch , the makecat options are at the end.
The Interchange Server runs.
Mo matter what I try I get :

[Tue Oct 31 20:21:27 2000] [error] [client] Premature end of
script headers: /home/httpd/html/firma/shop/cgi-bin/construct

the interchange error log says nothing only that the Interchange is running, in
the catalogs/logs/ there is only one file: usertrack with a few entries like:

"20001031        NURRvhTq: interchange
973020082               VIEWPAGE=admin/index
20001031        NURRvhTq: interchange
973020263               VIEWPAGE=admin/orderstats"

The wierd part is, you can log in to the admin interface, even use some of the
menus, but only some and no deeper than one level ... the pages you see get
listed in usertrack Iīve noticed.
you can try it at http://shop.ag-it.net/construct/ , the admin interface has
user: interchange with pass (I know and I will change it )

Everything else I tried got me with this or with "Interchange server unavailable
.... ." (wrong permissions I know )
I tried to change the socks file to 666, and everything else Iīve found on the
site, but there is allways "INET always works"

Any hints, ideas ? is it Interchange 4.6  ?

Thank you a lot in advance !

Andrei Gologan

Catalog name? construct
Server name? shop.ag-it.net
DemoType? construct
permtype? M
InterchangeUser? interch
CatUser? interch
MailOrderTo? e-mail@whaever.dot
CatRoot? /usr/local/interchange/catalogs/construct
CgiDir? /home/httpd/html/firma/shop/cgi-bin
CgiUrl? /cgi-bin/construct
Aliases? /construct
DocumentRoot? /home/httpd/html/firma/shop
SampleHtml? /home/httpd/html/firma/shop/construct
ImageDir? /home/httpd/html/firma/shop/construct/images
ImageUrl? /construct/images
TCP socket to use? 7786
Link host? localhost

and the rest defaults with mysql