[ic] Internal Server Error - Premature ending of script

Sonny Cook sonny@akopia.com
Fri, 3 Nov 2000 10:30:41 -0600 (CST)

A couple of things.  The #ifdefs aren't commented out.  The are c-style
ifdefs and so are preceded by a #.  Most if not all of the other hash
marked lines are comments.  Debugging is a separate issue from error
messages.  The debug file will be empty unless you actually enable the
debug code in the internals.  Interhcange logs errors on both global and
per catalog basis.  If you installed the rpm, I believe they can be found
in /var/log somewhere.  Otherwise, there is an error.log in both the
interchange install directory and the base directory for each catalog.
These errors are usually helpful.

Sonny Cook 

"I don't want fifteen dollars."  --Franklin D. Rooselvelt

On Fri, 3 Nov 2000, Steve wrote:

> Hi,
> In the past I have installed the cart a few times and solved any of the minor 
> issued I had. This time I'm installing on a bigger server (DELL PowerEdge w 
> dual 700 cpu's on preinstalled RH6.2) and have had several issues. Finally I 
> got it running but now I'm stomped.
> I can login as administrator and I get the Akopia config menu. 
>  Orders option gives "Internal Server Error".
>  Content option works.
>  Customers option gives "Internal Server Error".
>  Design option gives "Internal Server Error".
>  Items option gives "Internal Server Error".
>  Orders option works.
>  Merchandizing option gives "Internal Server Error".
>  Administration option works.
> Looking in the logs I find that Apache error log reports:
>  Premature end of script headers: /home/httpd/cgi-bin/vgd
> /tmp/icdebug only says debugging is on(?!?)
> error.log says: (minus date stamp)
>  - - Sending debug to /tmp/icdebug.
>  - - Low traffic settings.
>  - - Calling UI....
>  - - ...UI is loaded....
>  - - Interchange V4.6.0
>  - - Config 'vgd' at server startup
>  - - Using MySQL, DSN=dbi:mysql:test_vgd.
>  - - START server (27749) (INET and UNIX)
>  - - Accepting connections from localhost|127\.0\.0\.1
>  - - START server (27771) (INET and UNIX)   
> The part about accepting connections from localhost I'm not sure about. Other 
> than that there's no info why I now have a premature ending of script. 
> A French guy had some such problem which I think was related to rights. This 
> seems logical as I had to change the rights to make it work at all as it had 
> root prev''s. Once I changed them to the interchange user name it started. 
> I'm suspicious about the rights as I've never needed to change them on other 
> CVS installs. Maybe someone could give me a hand with who should have what 
> rights?
> Interestingly, all ifdef and endif's are commented out in the interchange cfg 
> file.
> Thanks,
> Steve
> _______________________________________________
> Interchange-users mailing list
> Interchange-users@www.minivend.com
> http://www.minivend.com/mailman/listinfo/interchange-users