[ic] Re: close_table error on a flat file database (solved!)

Mark Stosberg mark@summersault.com
Sat, 04 Nov 2000 01:01:33 -0500

Mark Stosberg wrote:
>   Here's a challenging question (or at least mysterious. :) We recently
> moved a server from one location to another and gave it a new IP address
> and a new name, although we are still mapping the old name for now. When
> we restarted Minivend (nothing had changed on the server besides it's
> IP), we got the following error for two stores:
> Can't call method "close_table" on an undefined
> value at /usr/local/mvend/lib/Vend/Data.pm line 409
> (This is with version 4.04).
> Posts on the mailing list gave solutions for this but said it was
> related to a MySQL database problem. This stores runs on an entirely
> flat file system. I tried deleting all the ".db" files, but that didn't
> help.
> I imagine it was something in the reboot that caused the problem. Any
> ideas on how to overcome this problem? Thanks!

This is a mysterious answer for a mysterious problem. Somehow the
catalog before the catalog giving the error (as listed in minivend.cfg)
was causing the error. The catalog before gave this error when
minivend.cfg restarted:
Configuring catalog market-dev...market-dev config error: products not a
database, cannot use as products file

When I commented out this entry in minivend.cfg, the stores following it
quit having problems. I thought store configurations were supposed to
autonomous. Could it be related that the problem store had the
"AllowGlobal" configuration turned on? 



personal website             }      Summersault Website Development
http://mark.stosberg.com/    {      http://www.summersault.com/