[ic] credit_card_info not encrypted in my report e-mail

Hans-Joachim Leidinger jojo@buchonline.net
Wed, 08 Nov 2000 20:49:04 +0100

Sonny Cook wrote:
> Joachim,
> I'm still looking into this.  The odd thing is that both the email and the
> saved file should be exactly the same.  Do you have EncryptProgram set to
> anything?


I'm in a muddle! Since MiniVend Version 3.14, I was able to solve all my
problems (ca. 95%) and with MiniVend Version 4.xx, I was able to get the
credit_card_info well and encrypted like all MV Version 3.xx too.
I use the same key for both. 

I'm wondering, why is the credit_card_info encrypted in any files of
../orders/<ordernumber> _and_ ..etc/tracking.asc _and not_ in my email

I've looked into the codes of Order.pm. But as a newbie in Perl, I can't
try out, was is going wrong. Have you any suggestions how to track or
debug the order process? I'm able to set the debug mode on. Where in the
debug output should my eyes searching for? Or can you tell me, which
part of the codes encrypt the credit_card_info? The codes seems to me
right, because it can recognize the setting of the variable "credit" and

Regarding your answer above, the odd thing is that both the email and
the saved file is _not_ the same. The saved files has the
credit_card_info encrypted and the emails _not_. I'm unsure about your
answer above. I use FreeBSD and Postilion (TkRat) as an emailreader and
it don't show any encrypted files or text automatically. So I believe.

If I set encrypt in my catalog.cfg, my whole email is encrypted. After
using "pggv", I see the email in normal plain text _and_ the
credit_card_info too. 

Any suggestions?

Thank you a lot!


-------------Hans-Joachim Leidinger---------------------