[ic] Re: Interchange and RaQs

Martin Kisser martyk@gmx.de
Thu, 9 Nov 2000 00:58:52 +0100

Hello Juzzin!

>     Has anyone here ever successfully installed Interchange on a RaQ?
> If so, did you use the RPM or the tarball?

i used the tar.gz - never tried it with the rpm

>     I am trying to install Interchange 4.60 on a RaQ 3 server. I have had
> difficult time installing the system, I've tried both the RPM and the
> tarball.
>     I've had the most success with the tarball. However, I ran into
> logging into the administrative interface (login/pass didn't work --
> non-sql) and the main screen repeatedly printed "error" where the store
> categories usually are.
>     Some pointers would be appreciated. (help! :) Thanks.

On my Server, hosted also on a RaQ 3, i had no problem installing the
4.6.0 -Release, the only problem was, that some environmental variables were
wrong (pathinfo AND script_name were something like
/cgi-bin/shop.cgi/index.html), so i ever got an "catalog not found"-error.

i edited the vlink or tlink (Perl):

(the code is written next to the "sub server_not_running" - declaration, but
in the main rountine)

#setting the name of the script manually

#removing the script name from the path info
my $pi = $ENV{'PATH_INFO'} || 'index.html';
$pi =~ s|/cgi-bin/shop.cgi/||i;
$pi =~ s|/cgi-bin/shop.cgi||i;

Then it worked ;-)

Hope this helps...
Martin Kisser