[ic] Make a Catalog with SQL

Alex alex@multimake.com
Sat, 11 Nov 2000 12:50:57 -0300

First thanks for help
I was checking step by step what you told me and these are the result:
1. I ran ./construct and i got *nothing*
2. I ran ./construct test=1 and i got this:
Status: 404 Not Found
Content-Type: text/plain

For this i think is not a cgi problem.
After that i tried with makecat without any database created before and
makecat created the database well, but without the tables, empty, after that
i browse the catalog by the admin interface wich it's working well but if i
browse the catalog by the customer side return the message error i'told you
If you have any other idea, no doubt in communicating to me it
Thanks again...

----- Original Message -----
From: delionsweb - minivend <minivend@delionsweb.net>
To: <interchange-users@minivend.com>
Sent: Friday, November 10, 2000 6:56 PM
Subject: Re: [ic] Make a Catalog with SQL

> First of all the Internal Server Error is NOT a catalog error per se ( >
> 90% of the time )
> It is more likely that it is a link CGI error (tlink or vlink copy
> installed in cgi-bin dir of the virtual web host.
> So first you have to see if you can run the <home dir>/cgi-bin/construct
> program.
> (This assumes that you told makecat that your cgi-bin directory is <home
> dir>/cgi-bin ...)
> You should get *nothing* when you run it like this: ./construct
> You should get this if you run: ./construct test=1
> Status: 404 Not Found
> Content-Type: text/plain
> Undefined catalog:
> If you don't get this then you need to keep trying the bin/makecat with
> different settings for the link CGI until you get a good result from the
> command line.
> Then you can try the browser.
> Note that you should get the CGI working regardless of whether the
> Interchange server is running or NOT. If the IC server is  NOT running the
> link program will tell you that it cannot connect. Command line and
> also - note that the default timeout is 30 seconds and add the delay to
> web server to that for the browser test.
> Until you get this working you will not know if you have a database
> or not ... ;-)
> Secondly, if you use the database option for the catalog, then you will
> lots of SQL statements fly past the FIRST time you start the interchange
> server with the new catalog. That is a good clue that the SQL database
> setup is working. You will NOT see these statements again UNLESS you drop
> that database and create it blank and restart the interchange server.
> Also, the makecat process for creating the catalog will complain about
> database creation if that database exists so it is better in my opinion to
> NOT create the database with the makecat if you know that it exists OR to
> drop the database before you run makecat.
> Good luck!
> At 02:00 PM 11/10/2000, you wrote:
> >Hello all:
> >Somebody knows why can't make a catalog that working with SQL?
> >I'have made a catalog based on the construct catalog type, when makecat
> >asked me what database i'wanted to use, i' answer mysql, i'gave the
> >name, created the database but empty, without tables, the tables
> >were in dbconf/mysql/name.mysql, so when i'want to in the catalog as a
> >it gave me an errormessage:
> >"Internal Server Error"
> >Thanks for help...
> >
> >
> >_______________________________________________
> >Interchange-users mailing list
> >Interchange-users@www.minivend.com
> >http://www.minivend.com/mailman/listinfo/interchange-users
> _______________________________________________
> Interchange-users mailing list
> Interchange-users@www.minivend.com
> http://www.minivend.com/mailman/listinfo/interchange-users