[ic] access permission bug?

Mike Heins mikeh@minivend.com
Sun, 19 Nov 2000 18:06:00 -0500

Quoting Terrance Chiang (terrance@ecnet.com.hk):
> Hello all
> 	I've been trying to set different administrators rights for different
> accounts with IC, but looks like there's some issues still remaining...eg
> 1) The "Administration" menu on the top menu bar of IC (4.6) is missing even
> though I've added all the permissioning possible for the administrator
> except for super user rights, however it seems to appear in the "quicklinks"
> section.  Without the "Administration" menu, the administrator won't be able
> to goto tax, shipping or payment sub menus.  I did attempt to correct this
> by, however failing miserably..so far anyway.
> 2) the "apply changes" function can't be used although the administrator
> permission rights has been checked for "apply changes"
> there are other ones, but maybe the interface is not fully developed yet?
> I will try to report more when I can definitely replicate it with the same
> sequence.
> So any suggestions, ideas on these bugs?

We are examining this in more detail for 4.7.x and 4.8. Right now it will
work if you set it up right and possibly fiddle a few pages, but it is far
from perfect.

In all likelihood, we will add the ability to create your own permission
levels to the permissions editor. You can then set up your own access
control for custom pages and reports with

	[if-mm advanced your_permission]
	Allow access
	No access

Akopia, Inc., 131 Willow Lane, Floor 2, Oxford, OH  45056
phone +1.513.523.7621 fax 7501 <heins@akopia.com>

My wife is great.  She doesn't care where I go, just as long as I don't
have any fun.  -- Lee Trevino