[ic] Install help please

delionsweb - minivend minivend@delionsweb.net
Mon, 20 Nov 2000 22:19:03 -0500

First of all the Internal Server Error is NOT usually a catalog error per
se ( > 90% of the time )
It is more likely that it is a link CGI error (tlink or vlink copy installed in cgi-bin dir of the virtual web host.

So first you have to see if you can run the <home dir>/cgi-bin/construct program.
(This assumes that you told makecat that your cgi-bin directory is <home dir>/cgi-bin ...)
You should get *nothing* when you run it like this: ./construct
You should get this if you run: ./construct test=1
Status: 404 Not Found
Content-Type: text/plain

Undefined catalog:

If you don't get this then you need to keep trying the bin/makecat with different settings for the link CGI until you get a good result from the command line.
Then you can try the browser.

Note that you should get the CGI working regardless of whether the Interchange server is running or NOT. If the IC server is NOT running the link program will tell you that it cannot connect. Command line and browser also - note that the default timeout is 30 seconds and add the delay to the web server to that for the browser test.

Until you get this working you will not know if you even have a database problem or not ... ;-)

Secondly, if you use the database option for the catalog, then you will see lots of SQL statements fly past the FIRST time you start the interchange server with the new catalog. That is a good clue that the SQL database setup (AND DBI) is working. You will NOT see these statements again UNLESS you drop that database and create it blank and restart the interchange server.
Also, the makecat process for creating the catalog will complain about database creation if that database exists so it is better in my opinion to a) NOT create the database with the makecat if you know that it exists OR b) to drop the database before you run makecat.
As Cameron indicated however, no tables in the database points more fingers at the datbase and / or DBI side of things.
My sledgehammer approach for most Perl module problems is to issue 'force install ...' commands in CPAN shell to make sure the modules are installed correctly.

In short:
1. Make sure the CGI link program is REALLY working - *without* the Interchange server also!
2. Tripple check the Perl module installations
3. Check the database setup independently - use something like MySQLMan from Gossamer Threads to make sure the DB server is fine.
4. Only then start beating up on Interchange ...

At 06:17 PM 11/20/2000, you wrote:
If you are seeing no errors in the interchange log files, and you have no tables in your database, this likely means something is wrong with your DBI.
There is an open bug for no errors when DBI is not installed or not working.
-----Original Message-----
From: interchange-users-admin@minivend.com [mailto:interchange-users-admin@minivend.com]On Behalf Of Leonel Silva
Sent: Monday, November 20, 2000 5:00 PM
To: interchange-users@minivend.com
Subject: Re: [ic] Install help please


The same is happening with me, I can create the catalog, the database (though no tables are created), log in the administration area but not in the store front page. The http error log also reports: Premature end of script headers:... .

I have DBI, and sql files in the catalog directory (../catalogs/catalog-name/dbconf/mysql/). I made a soft link from /tmp/mysql.sock to /var/lib/mysql/ and also tried to run mysqld with skip-grant-tables. No success at all, still can t connect to the front page and still the same error on http error log.

On the admin area I have the following information (though perl version is not correct, it is in fact 5.6):

Perl 5.006 (called with: perl)
LWP::Simple found (v1.32).
MD5 found (v2.01).
MIME::Base64 found (v2.11).
SQL::Statement found (v0.1016).
Safe::Hole found (v0.07).
Storable found (v1.006).
Tie::Watch found (v1.0).
URI::URL found (v5.02).
ftfile sort rand

Berkeley DB_File available (v1.72)
DBI enabled (v1.14), available drivers:


So, since I followed all the instructions I believe that error must be some place else.

Can you help me, please?

Leonel Joao Silva
Information Systems Manager

The Concessionaire of Madeira's International Business Centre

SDM Building
Rua da Mouraria 9, 1st floor
9000-047 Funchal

Tel: 351.291.201333
Fax: 351.291.201399