[ic] Localization causes misbehavior of basket? - additional info

Ton Verhagen ton@verhagen.net
Sat, 25 Nov 2000 20:02:37 +0100

It seems that changing the locale (entering the shop with a url: eg 
....process/locale/nl_NL/page/index) won't update array @Vend::Productbase. 
This array will always contain the initial values set in catalog.cfg (eg 
ProductFile products nl_products). However, $Config->{ProductFiles} will 
get updated when locale gets changed.

The result of the above behaviour is:
1. Searches will perform okay --> results come from the related products 
table ('products' for default, 'nl_products' for nl_NL)
2. When ordering an item, the info will come from the initial setting, not 
the locale related table.
When locale is set to nl_NL, all info in searches etc will show Dutch text. 
When a product is ordered, basket will show info in English (mv_ib has 
value 'products' instead of 'nl_products').

Hope this helps.


Ton Verhagen

At 07:22 PM 11/23/00 +0100, you wrote:
>At 12:50 PM 11/23/00 -0500, you wrote:
>>Quoting Ton Verhagen (ton@verhagen.net):
>> > Dear All,
>> >
>> > I encountered a problem while localizing the construct demo.
>> >
>> > Entries in locale database:
>> >
>> > code  en_US   de_DE   fr_FR   nl_NL
>> > ProductFiles  products        de_products     fr_products     nl_products
>> > products      products        de_products     fr_products     nl_products
>> >
>> > With these settings all searches perform well (as long as no file is
>> > explicitly mentioned in search).
>> > In other words, when a locale is in effect, e.g. nl_NL, the results come
>> > from the associated products table (nl_products). So far so good.
>> > However, when I order a product when nl_NL is in effect, the basket shows
>> > info coming from 'products' and mv_ib is set to 'products'.
>> > Is this intended behavior, have I overlooked something, or is this a bug?
>> >
>>Not intended. You can help by putting this code at the top of your
>>basket page and telling me what you see:
>>         push @out, "ProductFiles: ";
>>         push @out, join ",", @{$Config->{ProductFiles}};
>>         push @out, "\nDefaultLocale: $Config->{DefaultLocale}\n";
>>         push @out, "current locale: @@MV_LANG@@\n";
>>         return join "", @out;
>Have accessed the catalog with:
>Results from your code:
>ProductFiles: nl_products DefaultLocale: current locale:
>Why are there no DefaultLocale and current locale showing up?
>Hope you'll find out what's wrong.
>Thanks a lot.
>Ton Verhagen
>Interchange-users mailing list