[ic] New catelogue with MySQL problems

Greg Cope [email protected]
Tue, 03 Oct 2000 12:25:30 +0000


Greg Cope wrote:
> 
> Dave Barr wrote:
> >
> > >Dear All
> > >
> > >Been playing withn interchange with a view to a production roll out.
> > >
> > >I made a cat yesterday with Mysql support - Interchange made the DB -
> > >but upon restart gives the following in the logs:
> > >
> > >- - - [03/October/2000:07:44:17 +0000] - - Config 'fooshop' at server
> > >startup
> > >- - - [03/October/2000:07:44:17 +0000] - - Using MySQL,
> > >DSN=dbi:mysql:fooshop.
> > >- - - [03/October/2000:07:44:18 +0000] - - fooshop config error: Table
> > >'fooshop.orderline' doesn't exist
> > >- - - [03/October/2000:07:44:18 +0000] - - fooshop: config error.
> > >Skipping.
> > >
> > >I looked through the docs and cannot find any info - this may sound,
> > >lame but do I need to create that table ?
> >
> > -----
> >
> > Hi Greg,
> >
> > I had exactly the same thing happen when I created a new shop with
> > the same name as an older one after I had "dropped" that older shops
> > SQL database (mysqladmin)... you could have a different scenario but
> > I fixed it by giving the new catalog a new unique name (talk about
> > being lame  :-)
> 
> Hum ... I missed out the bit about creating a shop and then deleteing
> it.
> 
> This sounds like a kludge - but a help non the less.
> 
> Any any ideas why the recreation of a shop should cause this ?
> 
> Thanks for the prompt help -- appreciated.
> 
> Greg
> 

Bad form to follow up to myself - but I've some more info:


I recreated the shop with a new name (foo_shop)

- - - [03/October/2000:12:09:30 +0000] - - Using MySQL,
DSN=dbi:mysql:foo_shop.
- - - [03/October/2000:12:09:31 +0000] - - foo_shop config error: No
database object for table: userdb
> 
> Probable mismatch of Database directive to database type,
> for example calling DBI without proper modules or database
> access.
- - - [03/October/2000:12:09:31 +0000] - - foo_shop: config error.
Skipping.


The mysql log shows that I have an mv_test_create and orderline tables
being created.

I tried putting debugging on - to no avail.

Greg