[ic] New catelogue with MySQL problems

Dave Barr dave.barr@cricinfo.com
Tue, 3 Oct 2000 15:26:44 +0100

>  > Actually no I don't... :(
>>  But I figured after that that it wasn't a good idea to drop any SQL
>>  databases (I was trying to flush my system of *any* old files before
>>  upgrading to 4.5.6 latest CVS's). Have you ever created a shop on
>>  that particular machine with the name fooshop before?
>But I solved the problem.
>MySQL permissions.
>I operate a quite restrictive policy - i.e I gave the interchange user
>too few permissions - Index and Delete privileges where needed - a quick
>grant INDEX, DELETE ..... on ... fixed it.
>Sounds easy ... but it raises onther question:
>Why does interchange need "Creation style" priveleges such as index,
>delete and create - would it be possible to remove these and have them
>run at makecat time (under an admins privelege), so that interchange
>cats run under the least privileges  ?
>Also a minor bug but when doing the following with interchange running
>(on an RPM install):
>[root@localhost fooshop]# su -c "/usr/lib/interchange/bin/interchange
>-r" interch
>bash: /root/.bashrc: Permission denied
>The Interchange server was not running
>Which is suggest at the end of makecat, to restart the beast.
>The server starts and stops normally tho (just gets a bit confused)


Aha... thanks! I just tried the same and you're dead right, trying to 
work on too many things and not stopping to fix 'em, so kludge is the 
word :)

I'll avoid RPM, and stick to CVS which on the whole is working a treat for me.


Dave Barr        eCommerce Technical Manager      CricInfo Ltd
www.cricinfo.com   dave.barr@cricinfo.com    Tel: 01249 700748