[ic] Install Problem

Cameron B. Prince cameron@akopia.com
Fri, 13 Oct 2000 17:09:57 -0500

Hi Tom,

Find your vlink program. This is usually either the same name as the catalog
in a script-aliased directory, or catalog-name.cgi.

This program needs to be chmod 4755 and chowned to interch:interch or
whatever user interchange is running as.

Your error means the script ran, but couldn't communicate with the
interchange daemon. This is almost always caused by permissions.

Here's the site for construct something demo space 3:


total 13
drwxr-xr-x    4 construc construc     1024 Oct 12 16:32 .
drwxr-xr-x    9 construc construc     1024 Oct 12 15:43 ..
drwxr-xr-x    3 construc construc     1024 Oct 12 15:43 akopia
drwxr-xr-x    3 construc construc     1024 Oct 12 15:43 construct
-rwsr-xr-x    1 construc construc     7348 Oct 12 15:43 construct.cgi

Notice the: -rwsr-xr-x on construct.cgi

Good luck,


-----Original Message-----
From: interchange-users-admin@minivend.com
[mailto:interchange-users-admin@minivend.com]On Behalf Of Tom Compton
Sent: Friday, October 13, 2000 4:39 PM
To: Interchange-users@minivend.com
Subject: [ic] Install Problem

I recently installed interchange-4.5.7-1.rh6.i386.rpm.  Interchange
starts and runs.  construct starts, runs, and gives the following

"We're sorry, the Interchange server is unavailable...
We are out of service or may be experiencing high system demand,
please try again soon."

The FAQ says this is the result of permissions problems.

Both programs are running.  Permissions on all the files seem fine by
me.  I don't understand how the programs communicate, so I don't know
where to look for the problem.

Any help would be appreciated.


Tom Compton

Interchange-users mailing list