[ic] UI Admin fix for group.html

Zachary Matthews zac@mediapc.com
Thu, 19 Oct 2000 15:06:55 -0700

Here is a small problem with the CVS Interchange-4.5.8.  

I noticed in the Admin interface that Administration->Access->Groups
HTML page was not displaying the group names from the access.db table.
When I looked at the access.asc database I saw that groups are
implemented by preceeding the username with a semicolon

for a normal row ->     username=shipping
for a group row ->      username=:shipping

in any case, when I looked at the admin html code,
(~/interchange/lib/UI/pages/admin/group.html) and compared it with the
page that properly displays users
(~/interchange/lib/UI/pages/admin/access.html), I found that the loop
search for the groups page was missing the special form field, 'co=yes'.

BTW, can anyone tell me what 'co=yes' actually does?  The doc says:
"mv_coordinate        co  S   Enables field/spec matching coordination"

In any case, to fix the Admin functionality for Access->Groups, you need
to add the co=yes attribute to the search in group.html

replace this line ->
[loop search="fi=access/st=db/sf=username/se=:/bs=yes/tf=name"]
  <option value="[loop-code]">[loop-data access name]

with this line ->
[loop search="fi=access/st=db/co=yes/sf=username/se=:/bs=yes/tf=name"]
  <option value="[loop-code]">[loop-data access name]

PS I'm not sure if this is something I should point out in the bug
report, or here on the list, but since I hadn't yet signed up for a
bugzilla account, I thought I'd put it here.

Thanks to everyone for all the help thus far,