[ic] Flypage Problems

Ayayu Infomation desk info@ayayu.com
Tue, 31 Oct 2000 14:01:01 +0900

I have the same problem that flypage page does not exist.
I tested IC 4.6.0 on ISP which Perl version is Perl 5.00502 Free BSD
(called with: /usr/local/bin/perl) .
In may case, URL is
http://ayayu.com/cgibin/construct.cgi/os28108.html and error message is
Sorry, the page (os28108) was not found
The requested item (os28108) was not found. You can return to browsing
our catalog, if you wish.

On the other hand, Akopia's demo is worked on Perl 5.00503 (called with:
and URL shows like "
http://demo.akopia.com/cgi-bin/iccvsrw/os28005.html?id=vsNwB9Bu ".
iccvsrw means SUID on administration page.

I can't update perl version myself because of ISP, so this is the very
important issue for me.
Please give me some suggestion.


----- Original Message -----
From: Brad Smith <bsmith@select.net>
To: <interchange-users@minivend.com>
Sent: Tuesday, October 17, 2000 8:58 AM
Subject: [ic] Flypage Problems

> We tested another installation of V 4.5.7 on a second machine and the
> flypage worked fine.  The difference between the two machines is as
> follows:
> 1st Machine (flypage will not work):
>       Redhat V5.1, Linux 2.0.36, Perl 5.005_2
> 2nd Machine (flypage works):
>       Redhat V6.1, Linux 2.2.12, Perl 5.005_3
> Besides the obvious (upgrade)...any thoughts??
> >Sounds like your flypage might be in the "special_pages" directory
> >not in "pages". If that is the case, try copying it to pages and see
> >happens.
> >>Quoting Brad Smith (bsmith@select.net):
> >> We have been using Minivend for about 3 years now. Recently we
> >> upgraded to V4.04a and have 5 catalogs running just fine (flypage
> >> included). Last week, we installed Interchange V4.5.7b.
> >> Everything worked OK in our existing catalogs...except the flypage
> >> capability. When a request was made for a page (via the [page]
> >> tag) that doesn't exist, a "[sku#] not found" error was displayed
> >> rather than initiating the flypage. We did not change the
> >> catalog.cfg files on those existing catalogs after the upgrade.
> >> same error was also displayed with the construction example site
> >> which was installed with the new V4.5.7b (the flypage did not work
> >> when clicking on 'more info' for a product, but items could be
> >> to the cart). We then switched back to V4.04a and the flypage
> >> worked fine again in the existing catalogs. Probably something
> >> simple we are overlooking with the new install???
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> Brad Smith, Director of Web Development
> SelectNet Internet Services
> 2788 Loker Ave.
> Carlsbad, CA 92008
> ph: 760-438-9555
> fax: 760-438-1954
> web site: http://www.select.net
> _______________________________________________
> Interchange-users mailing list
> Interchange-users@www.minivend.com
> http://www.minivend.com/mailman/listinfo/interchange-users