[ic] Buggy Install?? Or User Error??

jojo@buchonline.net jojo@buchonline.net
Fri, 22 Sep 2000 09:57:55 +0200 (CEST)


Please, delete some old messages.

Regarding FreeBSD...have all the Interchange files, all the catalog
 files and the cgi file the same the permissions (user and group)?

In my case, Ive

# bin/minivend -u
Low traffic settings.
Calling UI....
....UI is loaded....
Interchange V4.5.6
Configuring catalog icsimple...Using MySQL, DSN=dbi:mysql:test_icsimple
done.
Interchange server started in UNIX mode(s) (process id 827)


# ls -al /www/mydomain/cgi-bin/icsimple 
-rwsr-xr-x  1 maxivend  maxivend  6304  7 Sep 11:16 /www/mydomain/cgi-bin/icsimple
mvend has logged on ttyp3 from :0.0.

ls -al /home/maxivend/etc/*
-rw-r--r--  1 maxivend  maxivend  3015  7 Sep 11:46 /home/ic/etc/makecat.cfg
-rw-r--r--  1 maxivend  maxivend  3015  7 Sep 11:46 /home/ic/etc/makecat.cfg.new
-rw-------  1 maxivend  maxivend     4 22 Sep 09:46 /home/ic/etc/minivend.pid
-rw-------  1 maxivend  maxivend     0 22 Sep 09:46 /home/ic/etc/mode.unix
srw-------  1 maxivend  maxivend     0 22 Sep 09:46 /home/ic/etc/socket
-rw-------  1 maxivend  maxivend    25 22 Sep 09:46 /home/ic/etc/status.icsimple
-rw-------  1 maxivend  maxivend  7473  6 Sep 12:51 /home/ic/etc/varnames

cat /home/maxivend/etc/minivend.pid
827

# top -d1 -Umaxivend | grep 827
  827 maxivend            2   0 15544K  3032K select   0:00  0.00%  0.00% perl


My catalog.cfg looks like

CATROOT         /www/mydomain/ic/catalogs/icsimple
CGIDIR          /www/mydomain/cgi-bin
CGIURL          /cgi-bin/icsimple
ALIASES         /icsimple
DOCUMENTROOT    /www/mydomain/html/icsimple
SAMPLEHTML      /www/mydomain/html/icsimple
IMAGEDIR        /www/mydomain/html/icsimple/images
IMAGEURL        /icsimple/images

and the minivend.cfg looks like

Catalog       icsimple /www/mydomain/ic/catalogs/icsimple /cgi-bin/icsimple /icsimple

Regards,

	Joachim






On 21 Sep, Beriah Dutcher wrote:
> Its a PIII 500Mhz/256MB RAM running FreeBSD 4.0
> 
> -----Original Message-----
> From: interchange-users-admin@minivend.com
> [mailto:interchange-users-admin@minivend.com]On Behalf Of Steve & Patti
> Getzinger
> Sent: Thursday, September 21, 2000 3:51 PM
> To: interchange-users@minivend.com
> Subject: Re: [ic] Buggy Install?? Or User Error??
> 
> 
>   Well if it is running your machine is not strong enough. Timing out. What
> OS
> are you using? Should have something similiar to
> /etc/rc.d/init.d/interchange
> start or restart. I am getting Interchange server busy messages when I try
> the
> site. In other words the site/server is not running.
> 
> Steve



-- 
Hans-Joachim Leidinger
buch online                 jojo@buchonline.net
Munscheidstr. 14            FAX: +49 209 1671441
45886 Gelsenkirchen         FAX: 0209 1671441