[ic] makecat bug on construct?

jojo@buchonline.net jojo@buchonline.net
Wed, 27 Sep 2000 09:59:54 +0200 (CEST)


On 25 Sep, Rob Zimmerman wrote:
> When it gets to docroot is suggests "constuct" instead of "construct":
> DocumentRoot? /usr/local/apache/htdocs/constuct same with 
> SampleHTML?/ImageDir? and then the strangest thing is at the ImageURL I 
> get:
> ImageUrl? /construct/images
>  is not a valid user name on this machine.
> [/usr/local/interchange/bin] root@mrsun(pts/7)   
> 
> My spelling is correct AND the user bubble is valid. /construct/images 
> should be a partial url? I dont get why it reports not a valid user.  Not sure if 
> this has been reported. src is pure CVS and Im running Solaris8. 

Hi Rob,

Ive reported some behavior with the newest makecat.
In my case, makecat is not able to recognize the user ($mvuid is not
set) and makecat has trouble with the ImageDIR and ImageURL, because
makecat ask you for the whole real path of the images and told you,
makecat is not asking for the URL. 

For example: /www/mywebspace/html/myshop/images

But looking into the catalog.cfg of construct, I see

ImageDir                __IMAGE_DIR__/
ImageDirInternal        http://__SERVER_NAME____IMAGE_DIR__/

In this case, I get

http:://www.mydomain.com/www/mywebspace/html/myshop/images....

and I see, the Variable SHARE_DIR is not using or not set and makecat
try to copy all ui images stuff to anywhere and break with "not
permission" error.

src is pure CVS too and Im running FreeBSD 3.4.

Joachim

-- 
Hans-Joachim Leidinger
buch online                 jojo@buchonline.net
Munscheidstr. 14            FAX: +49 209 1671441
45886 Gelsenkirchen         FAX: 0209 1671441