[ic] rpm -qlp interchan* output for me

Jon Jensen jon@akopia.com
Wed, 4 Apr 2001 16:29:17 -0500 (CDT)

On Wed, 4 Apr 2001, Dan B wrote:

> At 03:56 PM 4/4/2001 -0500, you wrote:
> >Nearly a month ago Jon suggested someone do:
> >rpm -qlp interchange-4.6.4-1.rh7.i386.rpm (edited to be my current version)
> >so the install locations could become familiar.
> >
> >I have tried this including tried with shorter interchange* variations
> >and continue to get the response 'package ... is not installed'
> Filename != rpm name.  I got confused about that when I was first learning 
> Redhat 5.0, too.  :-)
> Try     #rpm -q -a | grep interchange
> That should reveal the real name of the interchange package.  (Which will 
> probably result in a working rpm -qlp interchange, or rpm -qlp 
> interchange-4.6.4).
> It's too bad that there isn't really great up-to-date documentation on RPM, 
> but you might try rpm.org if you still have questions.

The manpage is pretty good on this topic, actually.

rpm -qlp uninstalled-rpm-file-name.rpm

is for RPM packages in a file (regardless of what's installed on the
system), while

rpm -ql interchange

operates on the Interchange package you already installed on your system
(if any).