[ic] Invalid catalog

Ed LaFrance edl@newmediaems.com
Fri, 13 Apr 2001 12:38:09 -0700

At 01:43 PM 04/13/2001 -0500, you wrote:
>I am a new user to Interchange. I am trying to set up the sample shopping
>cart 'construct' for my company. I get the index.html page to display, but
>when I click on any link I get an 'invalid catalog error'.

Never seen it!  Is that the  exact text of the error?

>Does anyone know
>what causes this and what I have to do to fix it?
>I tried reinstalling Interchange and creating the sample catalog againg
>(construct). I know get the error:
>         "The requested object does not exist on this server. The link you 
> followed
>is either outdated, inaccurate, or the server has been instructed not to
>let you have it. Please inform the site administrator of the referring

This sounds like a custom 404 (page not found) page.  Something is awry 
with your installation. Did you get this error when trying to go to 
http://www.yourdomain.com/construct, or 
http://www.yourdomain.com/construct.cgi/construct/ ?  You may want to 
double check the values for DOMAIN_NAME, CGI_URL, etc in 

- Ed L.

>I checked my permissions, and they all seem to be fine. The interchange.cfg
>has the line:
>         Catalog       construct /export/home/wittrock/catalogs/construct
>/construct.cgi /construct
>I don't know what else to check. I was reading an earlier posting that
>mentioned this problem and someone mentioned running Interchange as the user
>'interch'. How do I do that?
>Any help is greatly appreciated
>Chad M. Wittrock
>Programmer Analyst
>Gilchrist 255
>University of Northern Iowa
>Interchange-users mailing list

**** Virtual Hosting w/private IC Installation, $65/month! ****
New Media E.M.S.               Software Solutions for Business
463 Main St., Suite D          eCommerce | Consulting | Hosting
Placerville, CA  95667         edl@newmediaems.com
(530) 622-9421                 http://www.newmediaems.com
(866) 519-4680 Toll-Free       (530) 622-9426 Fax