[ic] Unable to submit order

Trond Arve Nordheim trond.arve@nordheim.no
18 Apr 2001 21:58:30 +0200


I've just set up a demo shop using the tutorial found on
developer.akopia.com as a guide. I have followed every step closely, and
everything works like it's supposed to, -except- order submission.

When I fill out the order form, fill inn the demo credit card number
(4111 1111 1111 1111) and the expire date (just a random date in the
future), I get a message saying (from pages/checkout.html):
"You left something important out:

Please go back to the checkout page and fill the form out properly."

Well, I don't get any info from that page so I checked the error.log,
but didn't find anything there either.

I've read through the mailing list archives and saw some post regarding
this, but I don't believe that the answers I got there is my issue; the
user clicked the stop-button, and when the page doesn't come from the
minivend-server (i.e. cached copy from a 'Back'-click or something).

I -know- the page comes directly from the minivend-server, and there's
no clicking on any buttons involved :)

I've tried this from 4 different computers with 4 different browsers
(Internet Explorer, Netscape, Mozilla and Lynx) with the exact same

The content of all my catalog-files is the exact same as in the
tutorial, just a cut and paste with every file. Also, if I set up the
'construct' catalog as described in the QuickStart-document that comes
with Interchange, I -am- able to submit my order, so I have really no
idea why I can't get this working on my own shop. I've studied the files
on the construct catalog without seeing anything I believe can be the

Anyone have any ideas?

Trond Arve Nordheim