[ic] CyberCash 3.3.1 and Interchange 4.6.5

Mike Heins mikeh@minivend.com
Tue, 24 Apr 2001 04:09:29 -0400

Quoting Dan Garwood (dgarwood@eprofitdesigns.com):
> This is a notice for the archives to save someone time on trying to
> integrate CyberCash 3.3.1. This is per their technical support, but the new
> version will hang at the MCKencrypt program when used with interchange on a
> redhat 6.2 system. The best solution till Mike gets Interchange 4.7 finished
> is to use the CyberCash 3.2 version of their program. If anyone needs this
> software, please contact me or CyberCash for this version. I may be wrong
> and Mike may have a fix for Version 3.3, but everything I tried would not
> work.

I don't have this version, and the last one I downloaded (just a few weeks
ago) was and worked.

I suspect they are using open2(), and if that is the case it is well
and truly hosed. We are a daemon process, and since we close STDIN and
STDOUT, that kills open2 unless they are clever about using fileno()
to get the handles.

Red Hat, Inc., 131 Willow Lane, Floor 2, Oxford, OH  45056
phone +1.513.523.7621 fax 7501 <mheins@redhat.com>

Light travels faster than sound. This is why some people appear bright
until you hear them speak. -- unknown