[ic] RPM Install procedure

Kurt@meridian-ds.com Kurt@meridian-ds.com
Fri, 27 Apr 2001 15:47:55 -0500

rpm -Uvh <name of rpm file here>
This will Upgade/Install you system.
you can then look in /usr/share/doc/interchange-4.6.5 and find pdf
I don't remember how I have been running makecat... it was in the docs

our system is similar.
problems I have seen so far.

SciptAlias /cgi-bin/ MUST be defined inside the <VirtualHost> for each
if you don't use <VirtualHost>... this doesn't apply.

After we installed the base system
created a store using a subdirectory of the primary server space...
didn't work till we got the ScriptAlias /cgi-bin/ setting correct.
lots of other problems... probably all tween keyboard and seat

tried again... this time as a virtual site...
answered a few questions wrong... fixed catalog.cfg file....
that corrected the bad answers and everything except admin images worked.
the system was referencing ...akopia/ui/navigation... for the images.
the only ...akopia/ui/... directory was in the system root area... not in
the virtual server directories.
using the ln -s /var/www/html/akopia /var/www/html/<virtdir>/akopia command
fixed that.
seems to work real well now.

Hope that helps

Kurt L Vanderwater

                    "Curt Hauge" <chc@mninter.net>                                                                             
                    Sent by:                              To:     <interchange-users@lists.akopia.com>                         
                    interchange-users-admin@lists.        cc:                                                                  
                    akopia.com                            Subject:     [ic] RPM Install procedure                              
                    04/27/01 03:31 PM                                                                                          
                    Please respond to                                                                                          

IC 4.6.5-1 rpm - Construct - Default DB - Redhat 7.0 - Perl 5.6

Hi list,

This is my first RPM installation (well, second attempt at first install).
What is the best way to install the RPM version? I can't seem to find the
exact steps in the archives or in the docs. I've searched install rpm,
install root, and read the readme.rpm file.

I have root on a fresh server. I plan to install IC 'as root' to the
directories. This server will host several IC sites which will be in
space (www.client1.com, www.client2.com). Clients will have access to their
space if desired. I installed as default group 'M'. Should I run makecat as
root, 'su interch', or should I 'su client1' to run makecat for each
catalog? I seem to have (had) permission problems after running makecat as
root so I think I also need to understand chown. Thanks for any help.

Curt Hauge

Interchange-users mailing list