[ic] user tag [encrypt] not found

Greg Hanson greg@valuemedia.com
Mon, 30 Apr 2001 09:39:46 -0700

> -----Original Message-----
> From: interchange-users-admin@lists.akopia.com
> [mailto:interchange-users-admin@lists.akopia.com]On Behalf Of Dan B
> Sent: Thursday, April 26, 2001 9:09 PM
> To: interchange-users@lists.akopia.com
> Subject: Re: [ic] user tag [encrypt] not found
> At 07:23 PM 4/26/2001 -0700, you wrote:
> >Hi all,
> >
> >I am having trouble getting the user tag encrypt Ed L
> supplied for the list
> >to be found on my server.  Getting error message:
> >
> >- - - [26/April/2001:21:58:08 -0400] - - valuet config
> error: Required
> >UserTag encrypt not present. Aborting catalog.
> > > In line 604 of the configuration file 'catalog.cfg':
> > > Require usertag   encrypt
> >
> >I have placed the tag in with the other user tags at
> >/usr/local/interchange/usertag/
> >file permissions and owners are the same as the other tags
> in the usertag
> >directory
> >
> >when that did not work I put it (entire usertag) into the
> interchange.cfg
> >file, although it already has
> >
> >#### Now including individual usertag files
> >
> >#include usertag/*
> >
> >  .
> >
> >Tried the tag in the catalog.cfg with AllowGlobal in
> interchange.cfg for
> >that catalog, but got strange errors referencing missing
> product files
> >in the ProductFile directive, although I have properly
> defined product files
> >in there and when I remove the tag everything reconfigs fine.
> >
> >I know I am missing something simple.... but can't lay my
> finger on it.
> >
> >Interchange 4.6.1
> >Perl  5.006
> >Redhat 7
> >
> >Thanks,
> >
> >Greg
> Quick guess:
> Do an octal dump (od -a encrypt.tag) and make sure you didn't
> get any weird
> characters in there (e.g. windows \r).  If you did get the CR
> ("\r") you
> can remove it with #tr -d "\r" encrypt.tag
> Dan Browning, Cyclone Computer Systems, danb@cyclonecomputers.com

Dan, it was not \r, but it was something very similar. Looking at the file
with "joe", I am getting a M with an underscore at the end of each line.  In
the octal dump (thanks for another tool by the way) it is a carriage return
or "cr".  I do not know what is adding this to the files, I have tried
different combinations of wordpad, notepad and j-edit, but am unable to get
rid of them.  I suspect the ftp process, I use wsftp le, but cannot see
anything that I can change in options to avoid this.  I did not have this
problem that I noticed up until *recently*.  I have *recently* started with
a satelite connection, Starband, using winproxy.  I guess there could be
something there, and I will experiment with going back to the modem for a
few files to see if that is it.

Anyway, I wanted to thank you for heading me in the right direction.  I
cleaned [enyrpt] tag up by hand, and it works great.  Thanks again to you,
and to Ed L in the first place for the tag, it is very useful.

> _______________________________________________
> Interchange-users mailing list
> Interchange-users@lists.akopia.com
> http://lists.akopia.com/mailman/listinfo/interchange-users