[ic] interchange dead and subsys locked after install of 4.6.3-1...

Webb, Malcolm malcolmw@upshot.com
Tue, 13 Feb 2001 11:18:13 -0800


I just downloaded the 4.6.3-1.rh6.i386 RPM and installed it, and my
interchange is no longer working. When I go to /etc/rc.d/init.d and do a 

./interchange start

I get the confirmation message back

[   OK   ]

saying that it has started successfully. But when I try to access construct,
I get interchange's "Server unavailable" message. I followed the
instructions in the mail archives for resolving this message and did a 

chmod 4755 construct

on the construct file in my cgi-bin directory, but this did not fix the
problem.  A check of the log files in /var/log/interchange revealed that no
errors were being passed to either error.log or construct.error.log.

Going back to /etc/rc.d/init.d and doing a

./interchange status

returned this message: "interchange dead and subsys locked"

So I rebooted the box, and tried again to start interchange - no luck, I
still get "OK" confirmation but it doesn't really start and a status check
shows I'm still getting the same "subsys" error message.

I looked through the mail archives again, and it says that this error may be
related to running interchange with PostgreSQL on the back end, but I am not
running interchange with PostgreSQL (my interchange install is vanilla)

However, I do have minivend installed on this same box, and my minivend IS
configured to use PostgreSQL - but that should not affect interchange right?

Also, prior to installing this latest version of IC, my interchange was
running fine.

Can anyone help?


Malcolm Webb