[ic] order reporting & purchase orders

Ken Dailey ken@desktech.com
Wed, 28 Feb 2001 02:47:55 -0600

I checked logs/log. Check and credit card orders appears as:
  #### begin 000002 #####
  Add main order 000002 to transactions: 1
  set credit_limit:
  Added os28068b to orderline: 1
  Inventory now: 98
  	Logout auto-created user: 1
  #### end 000002 #####
  Sending email copy of order 000002 to ken@desktech.com: 1

However, purchase orders appear as:
  #### begin 000004 #####
  There was an error adding to the transaction log.
  	Logout auto-created user: 1
  #### end 000004 #####
  Sending email copy of order 000004 to ken@desktech.com: 1

I checked the error log through the web-based administration and found these
three errors occurring:

{IP, DATE, TIME} construct /construct/construct.cgi/admin/genconfig.html
Can't read file '/home/xxxxxxxx/catalogs/construct/etc/status.construct'
with NoAbsolute set

{IP, DATE, TIME} construct /construct/construct.cgi/process.html search
error: Limit subroutine creation: bad limit creation code in coordinated
search, probably search group without search specification. at
/home/xxxxxxxx/interchange/lib/Vend/Search.pm line 703.

{IP, DATE, TIME} construct /construct/construct.cgi/process.html Attempt to
set userdb::password::U00004 in read-only table

Does this mean I have something setup incorrectly? I didn't change anything
out of the ordinary throughout the automated install. If it matters, the
purchase orders didn't register on the order reports at Akopia's demo site

Thank you,
Ken Dailey <ken@desktech.com> 612.825.0999
DeskTech Computer & Internet Services <http://www.desktech.com>

-----Original Message-----
From: interchange-users-admin@lists.akopia.com
[mailto:interchange-users-admin@lists.akopia.com]On Behalf Of Mike Heins
Sent: Tuesday, February 27, 2001 6:09 PM
To: interchange-users@lists.akopia.com
Subject: Re: [ic] order reporting & purchase orders

Quoting Ken Dailey (ken@desktech.com):
> Hello,
> I am very new to Interchange and have been working with the construct demo
> to familiarize myself with the program. I have a problem and I am not sure
> if it is a bug or if I missed something in the documentation.
> Any orders that are placed with the Purchase Order option (instead of via
> Check or Credit Card) do not show up on the Order report in the Admin
> Nor do they show up on the Customer report in the Admin area.
> I tried this out on my own installation of the demo and on the demo on
> Akopia's web site.
> Any ideas on how all orders can be included in these reports?

This is most likely a bug. I will note it as such -- there should be
indications in the error.log (did you check?). Also, you might look
and see what is in logs/log.

Red Hat, Inc., 131 Willow Lane, Floor 2, Oxford, OH  45056
phone +1.513.523.7621 fax 7501 <mheins@redhat.com>

People who want to share their religious views with you
almost never want you to share yours with them. -- Dave Barry

Interchange-users mailing list