[ic] Static Page Searches -Links to more matches

Mike Heins mikeh@minivend.com
Wed, 28 Feb 2001 11:31:08 -0500

Quoting Jimmy Eaton (jeaton@silverclicks.com):
> I am upgrading from 4.04 to the latest Interchange. When I generate static 
> pages the second static page of the Links to more matches  comes back with 
> nothing found. 
> The first static page comes back fine with the Links to more matches 
> (previous-1-2-3-next). When I click on 1 or 2 or 3 it comes back with 
> nothing found using a cached searched page. The static page that was 
> generated also has nothing found for the second page. I have deleted all 
> the temporary cached pages and tried it again. But the same thing happens.
>  When I click on next it works but is not using a static page but a cached 
> search page. The only difference between the links is the next page has 
> mi=static in the url while the 2nd, 3rd etc page links urls do not have it.
> No errors are showing up. I had to go ahead and set fi=products in the scan 
> searches or I would get an error that search file name was blank during 
> generation. I have ProductFiles set to products in the catalog.cfg.
> Am I missing a file, a variable setting or something.

The problem is that the mv_cache_key is not matching.  I never really
got it to work properly in all situations, if I recall. If it did it
was incidental.

I would use the new Design->Generate static UI interface, which takes
care of this by setting a shared search save file that can be retained.
The old "minivend -build catalog" is going away in the next version.

Red Hat, Inc., 131 Willow Lane, Floor 2, Oxford, OH  45056
phone +1.513.523.7621 fax 7501 <mheins@redhat.com>

The U.S. Senate -- white male millionaires working for YOU!  -- Dave Barry