[ic] Problems losing session & checkout

Hans-Joachim Leidinger jojo@leidinger.net
Thu, 04 Jan 2001 01:19:42 +0100

Robert Braver wrote:
> Greetings all,
> I've been working for several months on a new store and database to replace
> an existing commercial web order system that we found lacking.  Since this
> is my first posting, I'd like to say how impressed I am with the power and
> flexibility of Interchange, and express my appreciation for the developers
> and the participants on this list.
> I originally set things up with 4.5.6 and later updated to 4.6.0.  My
> project is highly customized and is based on the 'simple' template.  I am
> using a multi-page checkout which I noticed is no longer available with the
> 'construct' demo provided with 4.6.0 and 4.6.1.
> We finally switched over on New Years Day, and customer orders abruptly
> stopped coming in, despite our own testing from various machines with
> various browsers which revealed no problems.  After an otherwise very busy
> weekend with higher than normal traffic, we found it very odd not to have a
> single order after 18 hours.
> Today we received a number of telephone orders from customers who had
> difficulties ordering online.  The problems varied.  One customer clicked to
> order an item and "nothing happened."  Another was able to put something in
> his basket, but his machine "locked up" when he went to check out, requiring
> a reboot.  When he came back, the item was still in his cart but again
> things locked upon checking out.  Yet another customer was able to enter his
> billing/shipping address information, but reported that "nothing happened"
> when he clicked the 'NEXT ->' button to proceed.
> We have since received a small tricking of orders, and I spoke with one
> customer who was able to go back in and order online (while I was on the
> phone) and found that it worked the next time around.  So I'm wondering if
> some of the problem has to do with a cookie with session information not
> being set correctly, which would tie in with the total lack of problems from
> our various machines around here.
> The only problem I have been able to duplicate myself is if I disable
> cookies and try to check out.  Everything is fine until I get to the
> multi/final page, at which point you can see the session ID in the URL
> changing, and of course the basket is then empty.
> Any suggestions as to things to check would be most appreciated.
> BTW, the URL for the store is http://store.firmware.com
> Regards,
> Robert Braver
> Micro Firmware, Inc.
> _______________________________________________
> Interchange-users mailing list
> Interchange-users@lists.akopia.com
> http://lists.akopia.com/mailman/listinfo/interchange-users

It is difficult for me (an old german boy), to understand your problem
right. But without cookies and changing session id in the URL, have you
a line like

<INPUT TYPE="hidden" NAME="mv_session_id" VALUE="[data session id]"> 

in your form page? In most common case, without this line, you will lost
the right session id without cookies.

Hope this helps!

-------------Hans-Joachim Leidinger---------------------