[ic] Cybercash config problem

vic vic@anabolic.com
Wed, 24 Jan 2001 02:18:28 -0800

I am trying to get the cybercash mck working with Interchange.  I have the
mck working fine in test mode with the default pages and cart that come with
the mck installation.  I tested with the mck alone to make sure any
subsequent errors were not caused by the mck.  Using the P.O. option, I can
complete a transaction just fine, but when I enabled the cybercash
directives and attempted to do a cc checkout,

I was got the following error message:

search error: Limit subroutine creation: bad limit creation code in
coordinated search, probably search group without search specification. at
file://usr/lib/interchange/lib/Vend/Search.pm line 700.

A search of the archives suggested a perl upgrade and a subsequent piece of
information pointed to encryption.  This was tested without pgp installed or
enabled.  When I install and use with Interchange, there is an encryption
error in the error.log.  The only thing I am not doing that is blatantly odd
is I am NOT running this in an https session.  Specifically, I get the
following error message in process.html:

Credit Card Information (Can't figure out credit card expiration.)

I will also get a similar error message but ending "...credit card type"

Any help is greatly appreciated!