[ic] Problems with RAQ4

David Somner dave@htxtech.com
Wed, 24 Jan 2001 09:40:19 -0500


>It appears this needs a reprint...Raq's are a pain

>did you remember to say 'Y' to CGIwrap on makecat (the default for ALL raq's)?


>did you have all the CPAN modules installed?

I thought I did, but when I re-ran ./configure, it loaded some more

>>The Interchange daemon is up and running in the background on the
>>server, but for some reason, it cannot be found.
>>What's going on?  What do I have to do to make this work?

>If everything was install exactly as it was supposed to be than it's the Raq just acting up...

>on Raq's it can be a lot...
>lesson 1. once IC is running don't reboot...it a pain to get it running again

>First check the permissions and ownership on: the CGI-BIN, IC software, and the catalog

Okay, that's done.  I changed all the owners to "admin" and all the file
modes to 775

>Check site for any changes

>then try the command (in the IC directory) bin/restart
>It should give you a list of all catalogs and give a PID (showing that it is running)

It does that

>Check site for any changes

>and the last step (which usually works for me)
>(backup all your catalog info, user tags, etc. that is stored in the IC directory)
>goback to the setup directory (where you ran ./configure) and run ./configure again
>reinstalling it over the older version

Did that

>Check site for any changes

>if running, and if required put the backup information back in

>"Love interchange...starting to hate my Raq's"

Still not running.

If I run from /cgi-bin/construct.cgi, I get  a "File not found" error
with a nice akopia-looking interface.
If I run from /construct directory, I get starting splash page, and if I
select anything, I get the following error:

Undefined catalog: /cgi-bin/construct.cgi/index.html

Of source, if I select "login" I get the error for "login.html", etc.

What's going on?
I'm clueless!