[ic] Problems with RAQ4

Company InterNet Services info@4co.de
Wed, 24 Jan 2001 16:37:29 +0100

>If I run from /cgi-bin/construct.cgi, I get  a "File not found" error
>with a nice akopia-looking interface.
>If I run from /construct directory, I get starting splash page, and if I
>select anything, I get the following error:
>Undefined catalog: /cgi-bin/construct.cgi/index.html
>Of source, if I select "login" I get the error for "login.html", etc.
>What's going on?

Interchange is running at least... (showing the 404 in it's own look)
now it appears it can't find the catalog,
if you are just installing IC you don't need to back anything up (as you never changed anything)
so continue if you have changed settings or customized your catalog rename the catalog to xxx-bak and continue

Do you have a global CGI-BIN or do you have a CGI-BIN dedicated for this site?
This is what usually cause the 404's, the bin you specified doesn't have the files or that bin is not used by the site.

If you don't have a global bin, and don't want to make one,
(Enable CGI on site, but not SSI...security issue)
you need to make a directory to act as the cgi-bin
but not called cgi-bin..suggest cgi_bin or cgibin   chmod it as 771 rwx,rwx,--x      chown admin

[you can chmod to 777 while your testing/working...just put it back before you release the URL]
when you run makecat  use this dir as the cgibin  i.e. /home/sites/sitexx/web/cgi_bin

(Raq's seem to have CGI wrap problems on multiple directories called cgi-bin...
don't use the name and one less problem to deal with.  It's actually a conflict between the cobalt gui at ./cobalt and it's global
file admin ...although you can activate a global cgi-bin without trouble)

If using a Global bin (or want one):
If you do want a global CGI-Bin, it is the same procedure on Raq's as on Red Hat6

If it has already been made and you ran makecat, you have a path problem in the links.

P.S. To make life easier I made a ln -s /home/sites /www  so I can access site much faster...might lessen typing mistakes.
/www/sitexx instead of /home/sites/sitexx  :)