[ic] expireall and server --start fail to run in crontab (was: Where is checkstat.sh?)

Curt Hauge chc@mninter.net
Mon, 12 Mar 2001 21:10:14 -0600

Thank you Dan. I believe this is what I need, however, I can't seem to execute anything from my crontab for some reason. This may be a crontab thing. I have tried:

5,10,15,20,45,55 * * * * /home/myfiles/interchange/bin/interchange --start


5,10,15,20,45,55 * * * * /home/myfiles/interchange/bin/interchange --serve

These both work when executed from /interchange as

bin/interchange --start

but not from cron. Any pointers out there? This crontab worked fine for MV4.04 but not the IC4.6.3 tarball on Linux Mandrake 6.0. What could I have screwed up? Nothing appears in error logs in either /interchange or /catalogs/cat. It's like the crontab is not doing anything, although I know it is because it fails this also:

44 4 * * * /home/tgis/interchange/bin/expireall

(or expireall -r)

and reports to me via email as:

>From root  Mon Mar 12 04:44:01 2001
Return-Path: <root>
Received: (from root@localhost)
	by myhost.com (8.9.3/8.8.7) id EAA16611
	for mylogin; Mon, 12 Mar 2001 04:44:01 -0600
Date: Mon, 12 Mar 2001 04:44:01 -0600
Message-Id: <200103121044.EAA16611@myhost.com>
From: root@myhost.com (Cron Daemon)
To: mylogin@myhost.com
Subject: Cron <mylogin@myhost> /home/myfiles/interchange/bin/expireall
X-Cron-Env: <SHELL=/bin/sh>
X-Cron-Env: <HOME=/home/myfiles>
X-Cron-Env: <PATH=/usr/bin:/bin>
X-Cron-Env: <LOGNAME=mylogin>
Status: RO

Couldn't read interchange.cfg: No such file or directory

The file is definately there. I have checked spelling of everything. Can anybody point me in the right direction or offer tips to troubleshoot this?

Thanks all.


-----Original Message-----
From: interchange-users-admin@lists.akopia.com
[mailto:interchange-users-admin@lists.akopia.com]On Behalf Of Dan B
Sent: Monday, March 12, 2001 12:36 AM
To: interchange-users@lists.akopia.com
Subject: Re: [ic] Where is checkstat.sh?

At 11:14 PM 3/10/2001 -0600, you wrote:
>After converting a Minivend 4.04 site to Interchange 4.6.3, I can not find 
>checkstat.sh (which checks to see if the server is running and restarts it 
>if not) in the Interchange directory, nor can I get the old checkstat.sh 
>to work via my crontab after copying it to /home/myfiles/interchange/bin. 
>I know it used to be in the /eg directory of the source, but it is not in 
>the interchange-4.6.3/eg directory. My crontab looks like:
>5,15,25,35,45,55 * * * * /home/myfiles/interchange/bin/checkstat.sh>&2
>Is checkstat.sh still being used? Can I use the old one? If yes, what 
>changes are necessary to use the old one?

I think that checkstat.sh is not being used anymore in favor of bin/interchange

If I'm correct, bin/interchange will look at the .pid file to see if it is 
till running, and if not, it will start itself again.  Otherwise it will 
just go through init until it realizes it was already running, and not fork 
an additional copy.  So I think you could try a call to bin/interchange in 
your crontab.

>Thanks in advance.
>Curt Hauge
>Interchange-users mailing list

Dan Browning, Cyclone Computer Systems, danb@cyclonecomputers.com

Interchange-users mailing list