[ic] Problems on Xmission Solaris

Jason Kohles email@jasonkohles.com
Fri, 16 Mar 2001 09:14:55 -0500

On Thu, Mar 15, 2001 at 02:59:08PM -0700, Chris Bair wrote:
> Let's see... Is this the same Jason that carried the umbrella to hit 
> cars that tried to run him down while crossing the street? (I used to 
> work there too, you might remember, although I'm sure you tried to 
> forget!)
I knew I recognized your name, but I'm so bad at remembering names I couldn't
quite remember why I recognized it, so I took the safe route and didn't say

> I doubt I could get them to do the first two (although they sound 
> like the better alternatives) how might I go about doing the last 
> two? I tried setting up the catalog to use INET, rather than UNIX, 
> but given my inexperience with Interchange, it still gave me that 
> "unavailable" message.

That message indicates that the link cgi was unable to contact the interchange
server, without getting the ISP involved there are two main ways you can
solve the problem.

In order to start interchange running on the web server, you could make a cgi
script that ran the restart command on the web server itself, something as
simple as:

echo 'Content-Type: text/plain'
echo ''
$HOME/interchange/bin/interchange -r

put it somewhere web accessible and then load it from the browser and it should
restart on the web server, making it accessible to vlink.  Since your home
directory is NFS mounted, make sure interchange is not running on any of the
other servers and fighting over the files with the one on the web server.

The other option is to use tlink to connect over the network, when makecat
asks if you want to use INET or UNIX mode, choose INET, then set the host and
port to the server you will be running interchange on, and make sure to run
'interchange -r' on that server to get the interchange server running, then it
should connect over the network to the interchange server.

Jason S Kohles