[ic] Server question

Jim jdix@home.com
Tue, 27 Mar 2001 10:05:26 -0800


I gather that "usr/loca/..." is the same as "domainname/"
perhaps you misunderstood me. I'm setting up a site for a client. It is
It has it's own cg-bin area.

When I tar'ed the file, it did create everything rather quickly. But, when I run
"config", I got the following error:

----copy starts-----
Found Perl 5.00404 as /usr/local/bin/perl

If you get a CPAN error, rerun the configuration and it
should go away.

syntax error at Makefile.PL line 532, near ") for "
BEGIN not safe after errors--compilation aborted at Makefile.PL line 775.
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `test'.  Stop.
------ error copy ends ------

The way people seem to be discussing things  here, is as if they are runing a
server. I'm not. Have no access the server root, just domainname root. Is this
my problem?

I don't understand what you mean by "usr/loca/src". Here is what I did:
[1]- FTP'ed the tar file it to www.domainname.com/cgi-bin
[2]- Telnet'ed in and tar'ed it and it created a directory called
interchange-4.6.4 with a swack of files and sub-dirs uner it. Seeing that it
like a directory called "interchange", I rennamed the directory from
interchange-4.6.4 to interchange.
[3]- ran 'config and got the errors as noted above.

Whew... :)

Jim D

Jim Balcom wrote:

> > Am new to shopping carts and the such and am having problems.
> >
> > I've tar'ed the files to cgi-bin. After many trials and errors, am I
> > right in concluding that Interchange will not run from within (example)
> > = "www.domainname.com/cgi-bin/interchange" ??
> >
> > I also note that the tarball method created a foldr called
> > "interchange-4.6.4" with sub-dirs. The files, when looking through them,
> > PL's etc., want to look in "interchange". Hmmm
> >From what you have written, it appears that you have skipped a few steps.
> I downloaded the tarball into /usr/local/src (just my personal hang-up)
> I ran 'tar -xzvf interchange*'
> This created it's own sub-directory for interchange.
> Do a cd to that sub-directory and run ./configure
> This is going to install all of the stuff that you need to make the
> Interchange server work before you can set up any catalogs. I told mine to
> put it all in /usr/local/interchange - which is one of the places that it
> wanted to do it.
> I recommend that, as much as possible, you stick to the locations and the
> preferences that it wants to put things.
> NOTE: This process can take (literally) several hours. It needs to gather up
> a lot of things off of the Internet. The program is intelligent enough to go
> and get them and  to install them. I've played with too many packages that
> will make you go and find some other package, install it, and get it
> running, and then you have to come back and start over, and then go and get
> other packages. I've had to go several layers deep to get this all working.
> Interchange is not like that. It will go and get the stuff, install it and
> test it. But, frequently it needs to start all over again once it gets a
> necessary package installed. At the end, you may end up with an error. If
> you run ./configure again, after it's got everything in that it wants, you
> should get an error-free installation.
> It's ONLY after this that you can start installing catalogs. This sets up
> and installs the server. Without an operational server, you can't set up any
> catalogs or do anything.
> -= Jim =-
> _______________________________________________
> Interchange-users mailing list
> Interchange-users@lists.akopia.com
> http://lists.akopia.com/mailman/listinfo/interchange-users