[ic] More Authorize.Net GlobalSub Issues

Jeromie Clark jeromie@smoothjazz.com
Thu, 29 Mar 2001 21:21:40 -0600

HI All-

I've read *all* of the documentation I could find on the authorize.net 
issues, and am still having problems.
I'm running the store on iServer (FreeBSD) -- it's a slightly quirky 
environment -- but IC (4.6.4) runs fine in all other respects (MySQL 
support too).  My store essentially is a hacked version of construct.

I read all the documentation I could find, and tried to address those 
issues, but am still getting the following:
bad custom payment GlobalSub: authorizenet /cgi-bin/istore.cgi/process.html

I've included globalsub/authorizenet in the interchange.cfg.

I've added the MV_XXXX variables via KNAR as per the instructions -- tried 
placing them in my catalog.cfg file too...
I followed the suggestion to test the module with perl, and it executes 
fine (sans GlobalSub >>EOF and EOF lines).

I have Net::SSLeay and OpenSSL 0.9.4 is already installed by iServer.
Net::SSLeay sees it, but it's above my home directory.  My Secure Server 
Cert *is* installed and working.

I ran a test script consisting basically of use Net::SSLeay to confirm that 
Perl sees the module.

Are there other things I should be looking for?  It's pretty difficult to 
troubleshoot as it's so transparent.
Order submissions just return the user to the order page with an error 
alert, but no actual error displayed.


Jeromie Clark
VP of Information Technology
Direct Line: (877)626-9694