[ic] can't get interchange daemon to run.

Leon Harris leon@quoll.com
Sat, 31 Mar 2001 19:36:10 +0800

Hi all. Sorry for the repost - it seems the list didn't like my
signature on the last post. Whatever ...

Any help would be greatly appreciated.
I cant get interchange daemon to run - either the version I manually
compiled or the rpm.
I am currently using the rpm version for rh 6.x

when I run
/etc/rc.d/init.d/interchange start
I get an ok, but there is no daemon in my process table.
when I do a
/etc/rc.d/init.d/interchange status, I get the message :
interchange dead but subsys locked

there are no messages in
/var/log/messages or var/log/interchange/construct.error.log

if I manually run:
su -c "/usr/sbin/interchange -r" interch
no errors are reported.

If I run
strace   su -c "/usr/sbin/interchange -r" interch

it seems to exit cleanly with a munmap followed by a _exit(256) = ?
but nothing else. My instincts scream "perl installation problem" at me,

but my perl works fine, as far as I can see. What can I do to get a bit
more info to debug


on a p450 128 mb rh 6.0 but patched up to close security holes, apache
1.3.6  with about 20 or so full virtual hosts ( plus sundry 301