[ic] can't get interchange daemon to run.

cfm@maine.com cfm@maine.com
Sat, 31 Mar 2001 09:45:38 -0500

On Sat, Mar 31, 2001 at 07:36:10PM +0800, Leon Harris wrote:

> Any help would be greatly appreciated.
> I cant get interchange daemon to run - either the version I manually
> compiled or the rpm.
> I am currently using the rpm version for rh 6.x
> when I run
> /etc/rc.d/init.d/interchange start
> I get an ok, but there is no daemon in my process table.
> when I do a
> /etc/rc.d/init.d/interchange status, I get the message :
> interchange dead but subsys locked
> there are no messages in
> /var/log/messages or var/log/interchange/construct.error.log
> if I manually run:
> su -c "/usr/sbin/interchange -r" interch
> no errors are reported.
> If I run
> strace   su -c "/usr/sbin/interchange -r" interch
> it seems to exit cleanly with a munmap followed by a _exit(256) = ?
> but nothing else. My instincts scream "perl installation problem" at me,
> but my perl works fine, as far as I can see. What can I do to get a bit
> more info to debug
> this?

What about shell for user "interch"  or is that user "interchange" and
truncated?  What about limits, profiles and so forth?

Replace interchange with hello world.



Christopher F. Miller, Publisher                             cfm@maine.com
MaineStreet Communications, Inc         208 Portland Road, Gray, ME  04039
1.207.657.5078                                       http://www.maine.com/
Content management, electronic commerce, internet integration, Debian linux