[ic] Why am I always getting the default translation?

John Matecsa matecsaj at picassofish.com
Wed Aug 13 21:14:09 EDT 2003

To get things in the templates directory to translate I had to resort to

[if scratch mv_locale eq "fr_FR"]
Favoris Globaux
Global Favourites

John Matecsa <matecsaj at picassofish.com>
Picasso Fish Corporation

On Wed, 2003-08-13 at 06:44, Marc Brevoort wrote:
> Sorry to bother again,
> In a page I have a line saying
> [LC][getlocale][en_US]About Us[/en_US][pt_PT]Quem somos[/pt_PT][/LC]
> This line is always rendered to the value of [getlocale], regardless of
> the string returned by tag [getlocale] being en_US or pt_PT. In other
> words, for some reason I'm always getting the 'default' translation and
> never the specific one -- even if the translation is available for the
> given language regardless of what it is.
> Quoting the documentation, the [LC] ... [/LC] pragma pair permits
> specification of locale-dependent text.
>  [LC]
>            This is the default text.
>    [fr_FR] Text for the fr_FR locale. [/fr_FR]
>    [de_DE] Text for the de_DE locale. [/de_DE]
>  [/LC]
> This seems clear enough, if no translation is found the default text
> will be displayed. My catalog.cfg contains the following as locale
> setting:
> Locale          en_US LC_CTYPE C
> LocaleDatabase  locale
> meaning US english is the default language. But then at least the pt_PT
> translation should come through after [setlocale pt_PT]?
> What am I missing?
> Regards,
> Marc Brevoort

More information about the interchange-users mailing list