[ic] User Tag problem

Mike Heins mike at perusion.com
Wed Aug 27 12:08:57 EDT 2003

Quoting Tim Nelson (TNELSON at ECS-INC.com):
> This is bizzare (at least to me).  
> I have a UserTag defined as:
> UserTag ecs_load Order name table keyfield keydata where
> UserTag ecs_load Routine <<EOR
> sub {
>         my ($name,$table,$keyfield,$keydata,$where) = @_;
> ....
> And a call to it as:
>  $Tag->ecs_load({
>                 name => 'userdb',
>                 table => 'userdb',
>                 keyfield => 'username',
>                 keydata => $Session->{username},
>                 where => "" });
> The problem here is that the parameter $where seems to be always getting
> the value of $name.  It is like the UserTag handler is only allowing 4
> parameters
> and wrapping the 5th one.  
> Probably obvious, but I am just not seeing this...

(You don't mention the version here, so I might have wasted my time
 testing this on the latest.)

Not obvious to me, and I cannot duplicate the problem here. Try adding
this line to the file:

    UserTag ecs_load PosNumber 5

That will tell the argument parser how many arguments there are for
sure. It should figure that out without telling it, though.

Also try adding a dummy parameter in the Order list.

And are you sure you have no DOS-ish characters in the file?

Mike Heins
Perusion -- Expert Interchange Consulting    http://www.perusion.com/
phone +1.513.523.7621      <mike at perusion.com>

People who want to share their religious views with you
almost never want you to share yours with them. -- Dave Barry

More information about the interchange-users mailing list