[ic] Admin login problems after upgrade to 4.9.9

Scott Miller smiller at twincs.com
Tue Dec 2 11:44:56 EST 2003

>>>>> Hi All,
>>>>> I recently upgraded from Interchange 4.9.5 to 4.9.9. Previously, I 
>>>>> had
>>>>> upgraded from 4.8.7 to 4.9.5. I'm using the Foundation demo with no
>>>>> changes to the admin section. Running on RedHat 7.2 with MySQL. I
>>>>> upgraded using the cross-platform tarball and followed the
>>>>> instructions from the UPGRADE document.
>>>>> The main web site works great after the upgrade with no problems that
>>>>> I have noticed. I can login as a customer and not have any problems.
>>>>> However, the admin site is having login problems. I can login and it
>>>>> will display the main menu. If I click on any link, it them 
>>>>> bounces me
>>>>> back to the login page. If I login again, it then takes me to the 
>>>>> page
>>>>> I selected. If I click on another link, it them bounces me back to 
>>>>> the
>>>>> login page again. This keeps repeating until I get bored and move on.
>>>>> :-)
>>>>> I've reinstalled the Bundle::Interchange with no luck and I've 
>>>>> checked
>>>>> the error logs.
>>>>> Does any one have any suggestions for me?
>>>>> Thanks!
>>>>> Scott
>>>> I had this same problem in my Safari browser on my Mac. Camino works
>>>> fine, and does a better job with the DHTML anyways.
>>>> Try another browser?
>>>> Josh
>>> Thanks for the suggestion. I have tried it with IE 5.5, IE 6.0, and
>>> Netscape
>>> 7.1 with the same results. I'm thinking it is something with my IC
>>> configuration but I'm just not sure what.
>> I experience the problems you have mentioned from time to time, 
>> however, it
>> is usually fixed with an exit of IE or a reboot and a clearing of the
>> browser cache.
>> I know that you have tried several browsers so I wonder what the common
>> thread might be. Have all your test been from the same machine or 
>> different
>> machines?
>> Also, have you tried the 4.9.9 Demo at http://demo.icdevgroup.org
>> This might help localize it to a machine specific or server specific
>> problem.
>> -Gary
> Hi Gary,
> I've tried two different machines at home and two different machines 
> at work with the same results. I tried the 4.9.9 demo at 
> http://demo.icdevgroup.org and it worked wonderfully. Its really 
> looking like I probably did something to my IC installation. Thanks 
> for the suggestions. Please let me know if you have any other ideas or 
> pointers on where I should look.
> Scott

I still haven't been able to figure out this problem. Is there an easy 
way to totally disable the admin security? All administrators have full 
access to every thing within the admin site so I don't need any of the 
role functionality. I would then just use the web server to secure the 

This isn't my ideal solution but it would give me some more time to 
figure it out.

Thanks again for all of the suggestions.

More information about the interchange-users mailing list