[ic] Re: Setting up catalogs on multiple domains

Rick O'Neil ic at oneil.org
Mon Dec 8 15:26:53 EST 2003

>> Hello all,
>> For several months now I've been running (quite successfully) an IC 
>> 4.9.8
>> catalog on a dedicated server (with virtual hosting of several other
>> domains as well). Now I want to set up a catalog for one of the other
>> domains but no matter how I configure things I can't get the second 
>> catalog
>> to run on the second domain - whenever I go to the customer entrance I 
>> get
>> an internal server error. Additionally, IC is running as the user
>> [firstuser] which is the user that is associated with 
>> [firstdomain.com].
>> The user [firstuser] and [seconduser] are both in the same group and 
>> I've
>> tried running makecat as both users with the same results. In other 
>> words:
>> http://www.[firstdomain.com]/cgi-bin/[firstcatalog]/index.html
>> The above works fine and has been working fine ever since the initial
>> catalog creation
>> http://www.[seconddomain.com]/cgi-bin/[secondcatalog]/index.html
>> This results in an internal server error with no errors in either the
>> interchange or catalog error logs.
>> However, if I instead run makecat and set the cgi directory to that of
>> [firstuser] it works fine.
>> Example: 
>> http://www.[firstdomain.com]/cgi-bin/[secondcatalog]/index.html
>> At first I assumed that this was a permissions issue and thus I used 
>> in the
>> [seconddomain] home directory:
>> chown -R [firstuser] catalogs/[secondcatalog]
>> chown -R [firstuser] cgi-bin
>> At his point I'm stumped since all of the catalog files are owned by 
>> the
>> user [firstuser] as is the cgi script. Running both catalogs from
>> [firstdomain.com] is not an option and I know other people have gotten 
>> this
>> working. Unfortunately, I haven't been able to find anything in the
>> archives that has worked.
>> I would certainly appreciate any help anybody could provide. Let me 
>> know if
>> I need to provide any more information (like a log of my answers to 
>> makecat).
>> -Rick
>You didn't mention what your error logs say.

I did say that there was nothing in the catalog error log and nothing in
the IC (system) error log. I also checked my Apache error log and as
predicted the error there was too generic to be helpful:

Premature end of script headers:

>I'm running multiple catalogs on one IC, but all under one user. You 
>could install 4.9.9 to run as one user, and use the test variable as 
>mentioned in the UPGRADE file to test your catalogs. Maybe that would 

I've read through the release notes for 4.9.9 and it doesn't look like the
way the catalogs are configured or "run" is any different than in 4.9.8.
I'd rather not go through the upgrade process until 5.0 is released since I
have one currently running catalog. If I'm wrong about this I'm sure Mike
or one of the other IC gurus around here can correct me. 

I know that other people have gotten multiple catalogs each to run on their
own domain and I'd like to figure out what I'm doing wrong. I know I'm
close - I just don't know which direction to go in (it's like knowing the
grocery store is only 1 mile away, but not knowing which direction to
drive). If anybody can help me out with this I'd appreciate it - the
catalog is ready to launch except for this.


More information about the interchange-users mailing list