[ic] Re: Setting up catalogs on multiple domains

Rick O'Neil ic at oneil.org
Tue Dec 9 18:12:02 EST 2003

>You might want to make sure you have a tmp directory under the catalog 
>and that you have a directory for your session cache for the second catalog.
>Also make sure that the permisions on your interchange socket allow the 
>second catalog to write to the socket. On some systems with plesk I've 
>had to set the permissions to 0666 using the following in the 
>SocketPerms 0666
>Shawn Mathews
>shawn at stuckinrealtime.us


Thanks again for the tips. I do in fact have a tmp directory and a session
cache directory both under the catalog I'm trying to get going (as well as
the one I have running successfully). I did add the socket permissions line
to interchange.cfg, but that didn't seem to make any difference.

Other information that I've uncovered in looking around that may be useful:

I am in fact running plesk on my system - I found detailed instructions on
Interchangeville for running IC on a plesk system:

The main thing that is different is I wasn't running in INET mode - I was
running in UNIX mode. I tried running makecat as described in the message
using INET mode, but that doesn't make any difference (I still get an
internal server error when I try to go to the catalog). However, here is
where it gets interesting - I have been running IC in UNIX mode for
catalog1 on domain1 and I can run as many catalogs on domain1 as I want
(while using UNIX mode). If I switch to INET mode then try to go to the
catalogs the message I get for all domain1 catalogs is that the IC server
is unavailable, but for catalog2 on domain2 I continue to get an internal
server error.

The other difference that I see is that the user interchange is running as
isn't "interch" but rather the user for domain1. Since the user for domain1
and domain2 are both a member of the "psacln" group I didn't think it
necessary to run as "interch". However, the one difference I can think of
is that "interch", as described in the Interchangeville post, would be a
full shell account, but the account for domain1 is a plesk virtual host
account - could this cause the problems I'm seeing? It seems unlikely to me
since I did go ahead and create an "interch" user account and followed the
directions there to a "t" and I continue to get the same behavior from IC
(internal server error for catalog2 running on domain2).

I appreciate your help so far, Shawn, but do you, or anybody else, have any
other suggestions?


More information about the interchange-users mailing list