[ic] Has any managed to get subcatalogs to work under 4.9.8?

Mike Heins mike at perusion.com
Sun Jul 20 15:01:43 EDT 2003

Quoting Shawn Mathews (eyefivesupport at aol.com):
> I've tried everything to get subcatalogs to work under 4.9.8.
> There seems to be some problem when copying the settings from the main
> catalog to the sub-catalog.
> This is the error I Get:
> AC9BEFDE.ipt.aol.com - - [20/July/2003:11:25:43 -0500] hep
> cattest.eyefiveinc.com/hep/index.html Runtime error: do not know how to
> copy (?-xism:^(\/home\/psmerch\/eyefive_catalogs\/eyefive)) at
> /home/psmerch/intr498/lib/Vend/Util.pm line 766.
>   >
> I took everything out of my subcatalog definition except the following
> lines, because somebody (Mike Heins I think) thought I was using a regex
> style config variable in the subcatalog.
> -- hep.cfg --
> Variable CGI_URL /hep
> Variable SERVER_NAME cattest.eyefiveinc.com
> Variable IMAGE_DIR /images/hep
> VendURL    http://__SERVER_NAME____CGI_URL__
> SecureURL  https://__SERVER_NAME____CGI_URL__
> But no matter what I change, I still get the error? Any ideas? anybody 
> get it to work?

It has to do with a defaults setting, probably FileControl.

Try changing this line:

	# but set some first if appropriate


	# but set some first if appropriate
	set_defaults() unless $C->{BaseCatalog};

in lib/Vend/Config.pm.

Mike Heins
Perusion -- Expert Interchange Consulting    http://www.perusion.com/
phone +1.513.523.7621      <mike at perusion.com>

Function in chaos, finish in style. -- Unknown

More information about the interchange-users mailing list