[ic] problem with admin ui after update

Stefan Hornburg racke at linuxia.de
Mon Jul 21 21:49:42 EDT 2003

On Mon, 21 Jul 2003 20:26:45 +0200
Olaf Kolling <kolling at w3welt.de> wrote:

> Hello List,
> today i updated my interchange from 4.9.4 to 4.9.8
> Redhat 7.2
> Perl 5.6.0
> The catalog runs fine as far as i can tell but the admin ui tells me:
> -----------------
> Admin interface will not work properly.
> Please install needed Perl modules: 
> SQL::Statement 1.005 too high a version, need 0.1021 or lower. IMPORTANT: UI Database editors will not work properly. 
> Archive::Tar not found. Only needed for supplementary UserTag definitions.
> Archive::Zip not found. Only needed for supplementary UserTag definitions.
> Compress::Zlib not found. Only needed for supplementary UserTag definitions.
> Crypt::SSLeay not found. Payment interface links via HTTPS/SSL.
> Term::ReadLine::Perl not found. Gives you filename completion and command history in the makecat program. Not used otherwise.
> Tie::Watch not found. Minor: cannot set watch points in catalog.cfg.
> The easiest way to do this is to use the CPAN module and do:
> perl -MCPAN -e 'install Bundle::Interchange' 
> -----------------
> The ui ist just pure text without any graphics and tables/colors, i
> assume the css fails to load.
> The SQL::Statement IS Version 0.1021 (i looked into the source in
> /usr/lib/perl...)

Have you checked for SQL::Statement in another directory of Interchange's
Perl load path ? locate Statement.pm should help you.


LinuXia Systems => http://www.linuxia.de/
Expert Interchange Consulting and System Administration
ICDEVGROUP => http://www.icdevgroup.org/
Interchange Development Team

More information about the interchange-users mailing list