[ic] Can't delete items category (Interchange 4.9.8)

Stefan Hornburg racke at linuxia.de
Mon Oct 13 14:23:21 EDT 2003

On Mon, 13 Oct 2003 03:52:57 -0600
Art <art at alpentech.net> wrote:

> Setup fresh install since upgrade from 4.8.x to 4.9.8 never worked out.
> Used the foundation "tools" sample data.
> Using text files for db not MySQL or other DB server.
> Redhat 7.3 with kernel 2.4.18-24.7.x
> Apache 1.3.27 with suexec
> Perl 5.6.1.
> Safe::Hole v0.08, Bundle::LWP v1.09, LWP::Simple c1.35, etc. all show loaded 
> from the server info page.
> Can't find any listing on cpan or Internet for Vend::Table:Shadow (which error 
> lists), except for a vague mention on this mailing list that it's being 
> worked on by someone in the future (old archives).
> When I try to delete an item category using the metadata tables editor page 
> (which fails) the interchange error log reports the following:
> [ip obfuscated] gIj349vL:[ip obfuscated] - [13/October/2003:02:18:38 -0700] 
> alpentech2 /cgi-bin/[catalogname]/admin/flex_select.html Safe: Can't locate 
> object method "delete_record" via package "Vend::Table::Shadow" (perhaps you 
> forgot to load "Vend::Table::Shadow"?) at 
> /usr/lib/perl5/site_perl/5.6.0/i386-linux/Safe/Hole.pm line 78.

This problem has been partially fixed in current CVS - records are now
deleted properly. There is still [perl] code failing due to shadow


LinuXia Systems => http://www.linuxia.de/
Expert Interchange Consulting and System Administration
ICDEVGROUP => http://www.icdevgroup.org/
Interchange Development Team

More information about the interchange-users mailing list