[ic] IC/RH9 IC Server won't start - Please Help

AS news1 at dsl.pipex.com
Fri Oct 24 23:52:42 EDT 2003

> Hi all,
> Hoping someone can help me out here, I have a clean install of RH9 on
> machine for development, I have tried loading the non threaded perl
> from the ftp site as well.
> I tried to load interchange but it kept complaining about missing perl
> modules (even after installing the non-threaded rpm).
> I then tried loading the individual perl rpms that it was moaning
> but some of those wouldn't install because of perl conflicts.
> At this point I did a --nodeps install of
> I can get to the first page of IC where it has the Customer / Admin
> choice, so apache is up and running ok.
> I can't get the server to run though, I get the following list of
> when I try to restart the server. It looks like its complaining about
> perl quite a bit??
> I am a newbie to perl/linux & IC which doesn't help much.
> Thanks,
> Andy.
>From your shell type perl -MCPAN -e 'install Bundle::Interchange'
This will install the required perl modules


Well I tried that and lots of things flashed past on the screen, in the
meantime I had done a manual removal of the Perl5 directory and manual
install of the kitchinsink perl5 file from the rh9 ftp directory.

When I http to foundation I still can't get past the first screen, I
still get the server not running message. Things look different now when
I try to restart the server, it says:-

The interchange server was not running
Low traffic settings
Interchange v4.8.7
Configuring catalog foundation....Using Default DBM database....done

I have also tried doing a re-install without --nodeps and it is still
complaining about missing perl modules.

What can I do next, I can provide telnet access if anyone wants a look?


More information about the interchange-users mailing list